Как подготовить тест в Excel 2007

Электронные тесты в настоящее время широко применяются как в образовательных учреждениях при проверке знаний обучающихся, так и на предприятиях при проверки компетентности сотрудников. Электронный тест удобен тем, что компьютер сразу же выдает оценку или результат тестирования. Существуют различные программные средства  для создания электронных тестов.

Один из наиболее простых вариантов  – создать тест при помощи электронных таблиц Excel.  Для создания теста необходимо иметь  сам тест и систему оценки результатов тестирования.

Рассмотрим создание теста на примере создания теста для школьников, изучающих язык разметки гипертекста.  Ниже на рисунке приведен фрагмент теста уже оформленного на листе Excel, необходимо настроить для него автоматическую выдачу результатов.

Электронный тест в Excel

1)        Напротив каждого вопроса находится ячейка для ввода варианта ответа, для этих ячеек задаем следующие свойства:

  • устанавливаем внешние границы: Главная – Шрифт — Границы — Внешние границы;
  • снимаем защиту ячейки – щелкаем правой кнопкой мыши на выделенной ячейке и во всплывающем меню выбираем пункт Формат ячеек…, в диалоговом окне Списки выбираем вкладку Защита, убираем галочку перед опцией Защищаемая ячейка.

Эти пункты выполняем для всех ячеек, в которых предполагается ввод данных — это ячейки для ввода персональных данных и ячейки для ввода выбранного варианта ответа на вопрос.

2)        Устанавливаем признак правильного ответа. В соседней ячейке рядом с ячейкой ввода варианта ответа (в примере ячейка F4)  вводим формулу, которая выводит «1» при правильном ответе и «0» при неправильном ответе. Для ввода формулы можно воспользоваться мастером функций либо ввести формулу вручную в ячейке, в данном примере используем функцию =ЕСЛИ(E4=2;1; 0):

Функция ЕСЛИ

В логическом выражении Е4=2, сравниваем с «2», так как под номером 2 находится правильный вариант ответа и если в ячейке Е4 будет введено 2, то в ячейке F4 результат будет «1», иначе – «0». Данную функцию копируем напротив каждой ячейки ввода варианта ответа, меняем только номер правильного ответа.

3)        Подсчитываем набранное количество баллов. В конце теста суммируем значения по столбцу с признаком правильного ответа. В конце теста под всеми ответами подсчитываем количество единичек (правильных ответов ) вводим функцию СУММ. Для приведенного примера в ячейке F37 вводим =СУММ(F4:F36) .

Функция СУММ

4)        Оцениваем результат тестирования в соответствии с набранным количеством баллов. В данном примере принята следующая схема соответствия:
10 баллов – оценка «5»,
9-8 баллов – оценка «4»,
7-4 баллов — оценка «3»,
меньше 4 баллов – оценка «2».
Для принятого оценивания следует ввести формулу: =ЕСЛИ(F37=10;5;ЕСЛИ(F37>=8;4;ЕСЛИ(F37>=4;3;2))) в ячейке Е37.

Вместо принятого школьного оценивания можно использовать текстовый эквивалент – «отлично», «хорошо» и т.п., тогда формула будет выглядеть так: =ЕСЛИ(F37=10;»отлично»;ЕСЛИ(F37>=8;»хорошо»;ЕСЛИ(F37>=4;»удов.»;»неудов.»))).

5)      Скрываем признаки правильных ответов. Столбец F, в котором занесены функции, выдающие признак правильного ответа, скрываем, чтобы он не был виден тому, кто проходит тест. Для этого выполняем следующее – щелкаем правой кнопкой мыши на заголовке столбца, во всплывающем меню выбираем пункт Скрыть.

Как скрыть столбец в Excel

6)      Защищаем лист от редактирования: РецензированиеИзмененияЗащитить лист. В диалоговом окне Защита листа включаем две опции: Защитить лист и содержимое защищаемых ячеек, выделение незаблокированных ячеек и вводим пароль. Защита листа не позволяет редактировать данные на листе, доступны будут только те ячейки, для которых была снята защита (эти действия были выполнены в пункте 1), в примере это ячейки для ввода вариантов ответов и персональные данные.

Все, тест готов!

О том, как представить результаты тестирования нескольких персон в виде диаграммы читайте в статье «Диаграммы в Excel. Гистограмма».

Поделиться в соц. сетях

Опубликовать в Google Plus
Опубликовать в Мой Мир
Опубликовать в Одноклассники

Также на эту тему, Вы можете почитать:

Комментариев: 2 на “Как подготовить тест в Excel 2007

  1. Красавец

    Спасибо большое за разъяснения! Все получилось!

    Reply
    1. Семакина Post author

      Рада, что статья оказалась для вас полезной!

      Reply

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *